1

Closed

LtiLibrary 1.4.3 is built against System.Web.Http 5.0

description

Hi,
latest version of ltilibrary available via nuget is built against
System.Web.Http, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 (Fully-specified) (WEb.API 5.0)

But I use higher version (5.2 is the latest one).

So now I get SGEN loader exception when building project in Release model

app build log is attached
Closed Sep 19, 2014 at 4:27 AM by afmiller
I just posted LtiLibrary 1.4.4 which is built against 5.2.2.

comments

afmiller wrote Aug 22, 2014 at 7:01 PM

Yes it is. I'll look into updating. In the mean time, you might be better off building your own copy.

evgenyvaliukevich wrote Aug 25, 2014 at 2:02 PM

Yes I have working local build.But on the project I work on we have policy to use nuget packages.

So I'm eager when you will publish new version to nuget.

Thank you in advance.

afmiller wrote Aug 25, 2014 at 2:16 PM

Have other non-Microsoft packages on NuGet updated to latest?

evgenyvaliukevich wrote Aug 26, 2014 at 8:42 AM

For now we upgraded WebApi to the latest (5.2) that why issue appreared